ez2view Installer

 

Older
May 2018 Release

Leading Edge

Bleeding Edge

version 7.4.0.40
You could choose to use the older version, which was released in May 2018 as noted in the Release Notes.

To the future
v7.4.5.665 (6 July 2020) improves the display of MW generation and interconnector information in time travel – see the release notes.
——

Prior versions include:

1) v7.4.5.658 (19 May 2020) contains various enhancements – including updated Schematics for new stations in production and pre-production
2)  v7.4.5.634 (30 Jan 2020) with new ‘NEM Prices Widget (BETA)’
Versions above require minimum MMS Data Model v4.28
(or ez2update v5.5, if you used that to update your MMS)
——
v7.4.5.333 (9th Aug 2019) is the most recent pre-release that is compatible with:
1)  ez2update v5.4 and
2)  prior versions of the MMS Data Model

These versions require minimum MMS Data Model v4.28

(or ez2update v5.5, if you used that to update your MMS )

No

Latest Functionality

We build new versions of ez2view almost every week, sometimes several versions (with new increments in functionality that we’re working on).

We do this as part of our Agile development methodology outlined here.

Yes
Yes

Automated Tests Passed

Every time changes to the software are checked in, our automated build process runs, including automated testing. Installers are only uploaded if all automated tests pass.

Yes Yes
Yes

Some Manual Testing Passed

When “Bleeding Edge” versions have passed some limited manual testing, we manually list them so you can access.

Yes No
Yes

Systematic Manual Tests Passed

We only run through an extensive manual batch of tests on the occasions when we seek to make a Full Release of the software.

No No
Yes

Documentation

There is extensive online help linked behind the “?” marks at the top-right of each widget.

We only systematically update this documentation each time we make a full release.

No No

Licence Agreement

Please review the licence agreement, which will apply to your full licence of ez2view.


Installation Instructions

Please refer to the installation instructions before installing ez2view.


.NET Framework 4.7.1

To use the MSI installers you will require the .NET 4.7.1 Framework, and any other items identified by the MSI when you run it.

ez2view v7.4 and above requires an upgrade to the .NET Framework. You will need to install or upgrade to .NET Framework 4.7.1 before installing or upgrading to ez2view v7.4.0.

If you are unsure whether you have the correct .NET Framework installed on the machine that will be running ez2view, we suggest you download and run the .NET Framework Installer linked below – it won’t make any changes if the correct .NET Framework is already installed.

The .NET Framework 4.7.1 must be downloaded and installed before the ez2view installer is run if you don’t already have it.

Download the .NET Framework Standalone Installer

Alternatively, you can simply download the ez2view MSI Installer, and it will tell you if the .NET Framework 4.7.1 needs to be installed.